频道栏目
首页 > 网络 > 其他 > 正文

世界杯投注官网

2019-04-10 12:38:46           
收藏   我要投稿

VRRP工作原理

名称:VRRP 工作原理
实验需求:
1.SW1与SW2是VLAN 10 20 中的网关;
2.SW1与SW2启用 VRRP,虚拟网关为 1.250 及2.250
3.确保SW1为vlan20的主网关 SW2为vlan10的主网关;
4.确定 VRRP 发送报文方式、协议号、目标地址
-发送方式:组播
-协议号:112
-目标地址:224.0.0.18 (表示所有的VRRP路由器
5.确定 VRRP 发送报文周期
-周期:1s
6.确定 VRRP 默认优先级
-默认是:100 (刚才的200,是人工修改的)
-抓包时,刚才抓到的全都是 主网关 发送的 VRRP 报文;备份网关是不发送VRRP报文的;
配置步骤:
1.配置终端设备;
2.配置网络设备;
世界杯投注官网配置交换设备
创建 VLAN ->配置接口类型和所属于 VLAN
世界杯投注官网配置路由设备
配置网关IP
3.配置 VRRP
启用VRRP,配置虚拟 IP
调整优先级,确保 SW1为vlan20 SW2为vlan10的 主网关
4.验证与测试
*查看每个路由器的 VRRP 状态

PC-1 Ping 1.250, PC-2 Ping 2.250 通过抓包确定数据转发路径

配置命令:
PC-1:
192.168.1.1
255.255.255.0
192.168.1.250 ->必须配置为虚拟网关的IP地址;

PC-2: 
   192.168.2.1
   255.255.255.0
   192.168.2.250 ->必须配置为虚拟网关的IP地址;                                
sw3:
  undo terminal monitor
  system-view
  sysname SW3 
  vlan batch  10 20   世界杯投注官网 创建 VLAN 10  20  
  quit 
  interface gi0/0/3 世界杯投注官网 接口加入到 VLAN 10 
        port link-type access
    port default vlan 10 
    quit 
  interface gi0/0/4 世界杯投注官网 接口加入到 VLAN 20 
        port link-type access 
    port default vlan 20 
    quit 
  interface gi0/0/1 世界杯投注官网 接口加入到 VLAN 的trunk 模式
    port link-type trunk 
    port trunk allow-pass vlan all
    quit 
       interface gi0/0/2 世界杯投注官网 接口加入到 VLAN 的trunk 模式
    port link-type trunk 
    port trunk allow-pass vlan all
    quit 

SW1:
undo terminal monitor
system-view
sysname SW1
[SW1]vlan batch 10 20 // 创建vlan 10 20
interface gi0/0/2
port link-type trunk
port trunk allow-pass vlan all //将交换机SW1用trunk模式和SW3相连通
quit
[SW1]interface vlanif 10
[SW1-Vlanif10] ip address 192.168.1.253 24 // 设置vlan10的真是网关地址

      [SW1-Vlanif10]vrrp  vrid 10  virtual-ip 192.168.1.250  //设置vlan10的虚拟网关地址,默认优先级100
  [SW1]interface vlanif 20
      [SW1-Vlanif20]  ip address 192.168.2.253 24        //设置vlan20的真是网关地址 
      [SW1-Vlanif20]vrrp  vrid 20 virtual-ip 192.168.2.250
      [SW1-Vlanif20]vrrp  vrid 20 priority 200           //设置vlan20的虚拟网关,并且将优先级设置为200 
                                                         成为vlan20的主网关

SW2:
undo terminal monitor
system-view
sysname SW2
[SW2]vlan batch 10 20 // 创建vlan 10 20 所有vlan的信息必须保持一致,以免出现不通等情况
interface gi0/0/2
port link-type trunk
port trunk allow-pass vlan all //将交换机SW2用trunk模式和SW3相连通
quit
[SW2]interface vlanif 10
[SW2-Vlanif10] ip address 192.168.1.254 24 // 设置vlan10的真是网关地址

      [SW2-Vlanif10]vrrp  vrid 10  virtual-ip 192.168.1.250  //设置vlan10的虚拟网关,并且将优先级设置为200 
      [SW2-Vlanif20]vrrp  vrid 10 priority 200                 成为vlan20的主网关
  [SW2]interface vlanif 20
      [SW2-Vlanif20]  ip address 192.168.2.254 24        //设置vlan20的真是网关地址 
      [SW2-Vlanif20]vrrp  vrid 20 virtual-ip 192.168.2.250    //设置vlan20的虚拟网关

验证命令:
display vlan ->查看 vlan 以及与 接口的对应关系;
display vrrp ->查看 vrrp 的状态,以及优先级;

需要掌握的内容:
@ VRRP的网关角色:
-主网关
-备份网关
-虚拟网关
@ 知道 VRRP 的默认优先级
@ 知道 VRRP 选择主/备网关的原则
-首先,比较优先级,越大越好;
-优先级相同,比较IP地址,越大越好;

相关TAG标签
上一篇:路由器OSPF的基本概念与工作过程-学习的路上,我们不孤单-51CTO博客
下一篇:NAT,Easy IP-Debug The Life-51CTO博客
相关文章
图文推荐

关于我们 | 联系我们 | 服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑--致力于做实用的IT技术学习网站